soc: loongson: use resource_size() helper function

Message ID Y6TM4ZidDExh8SPx@qemulion
State New
Headers
Series soc: loongson: use resource_size() helper function |

Commit Message

Deepak R Varma Dec. 22, 2022, 9:32 p.m. UTC
  Use the resource_size() function instead of a open coded computation
resource size. It makes the code more readable.

Issue identified using resource_size.cocci coccinelle semantic patch.

Signed-off-by: Deepak R Varma <drv@mailo.com>
---
Note: Proposed change is compile tested only.

 drivers/soc/loongson/loongson2_guts.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--
2.34.1
  

Comments

Deepak R Varma Jan. 7, 2023, 8:10 p.m. UTC | #1
On Fri, Dec 23, 2022 at 03:02:17AM +0530, Deepak R Varma wrote:
> Use the resource_size() function instead of a open coded computation
> resource size. It makes the code more readable.
>
> Issue identified using resource_size.cocci coccinelle semantic patch.
>
> Signed-off-by: Deepak R Varma <drv@mailo.com>
> ---

Hello,
Requesting a review and feedback on this patch proposal?

Thank you,
./drv
  
Deepak R Varma March 1, 2023, 7:38 p.m. UTC | #2
On Sun, Jan 08, 2023 at 08:57:48PM +0800, Huacai Chen wrote:
> On Sun, Jan 8, 2023 at 4:10 AM Deepak R Varma <drv@mailo.com> wrote:
> >
> > On Fri, Dec 23, 2022 at 03:02:17AM +0530, Deepak R Varma wrote:
> > > Use the resource_size() function instead of a open coded computation
> > > resource size. It makes the code more readable.
> > >
> > > Issue identified using resource_size.cocci coccinelle semantic patch.
> > >
> > > Signed-off-by: Deepak R Varma <drv@mailo.com>
> > > ---
> >
> > Hello,
> > Requesting a review and feedback on this patch proposal?
> Reviewed-by: Huacai Chen <chenhuacai@loongson.cn>
> But I think this should be merged through soc@kernel.org maintained by Arnd.

Thank you Huacai. Appreciate your time.

Hello Arnd,
Can you please tell me if I need to do anything further to have this merged as
suggested by Huacai?

Thanks,
./drv

> 
> Huacai
> >
> > Thank you,
> > ./drv
> >
> >
> >
  

Patch

diff --git a/drivers/soc/loongson/loongson2_guts.c b/drivers/soc/loongson/loongson2_guts.c
index bace4bc8e03b..aba4f8832805 100644
--- a/drivers/soc/loongson/loongson2_guts.c
+++ b/drivers/soc/loongson/loongson2_guts.c
@@ -107,7 +107,7 @@  static int loongson2_guts_probe(struct platform_device *pdev)
 	guts->little_endian = of_property_read_bool(np, "little-endian");

 	res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
-	guts->regs = ioremap(res->start, res->end - res->start + 1);
+	guts->regs = ioremap(res->start, resource_size(res));
 	if (IS_ERR(guts->regs))
 		return PTR_ERR(guts->regs);