[v2] mm/swapfile:__swap_duplicate: drop redundant WRITE_ONCE on swap_map for err cases

Message ID 20240221210845.13488-1-21cnbao@gmail.com
State New
Headers
Series [v2] mm/swapfile:__swap_duplicate: drop redundant WRITE_ONCE on swap_map for err cases |

Commit Message

Barry Song Feb. 21, 2024, 9:08 p.m. UTC
  From: Barry Song <v-songbaohua@oppo.com>

The code is quite hard to read, we are still writing swap_map after
errors happen. Though the written value is as before,

 has_cache = count & SWAP_HAS_CACHE;
 count &= ~SWAP_HAS_CACHE;
 [snipped]
 WRITE_ONCE(p->swap_map[offset], count | has_cache);

It would be better to entirely drop the WRITE_ONCE for both
performance and readability.

Signed-off-by: Barry Song <v-songbaohua@oppo.com>
---
 -v2: drop goto according to Andrew, Thanks!

 mm/swapfile.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
  

Patch

diff --git a/mm/swapfile.c b/mm/swapfile.c
index 556ff7347d5f..7cb6d9a2d51d 100644
--- a/mm/swapfile.c
+++ b/mm/swapfile.c
@@ -3320,7 +3320,8 @@  static int __swap_duplicate(swp_entry_t entry, unsigned char usage)
 	} else
 		err = -ENOENT;			/* unused swap entry */
 
-	WRITE_ONCE(p->swap_map[offset], count | has_cache);
+	if (!err)
+		WRITE_ONCE(p->swap_map[offset], count | has_cache);
 
 unlock_out:
 	unlock_cluster_or_swap_info(p, ci);