[RFC] workqueue: fix cast warnings on i386

Message ID 20230429044506.24843-1-rdunlap@infradead.org
State New
Headers
Series [RFC] workqueue: fix cast warnings on i386 |

Commit Message

Randy Dunlap April 29, 2023, 4:45 a.m. UTC
  Add casts to avoid int-to-pointer-cast warings on i386 or UML for i386:

../kernel/workqueue.c: In function ‘get_work_pwq’:
../kernel/workqueue.c:713:24: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
  713 |                 return (void *)(data & WORK_STRUCT_WQ_DATA_MASK);
      |                        ^
../kernel/workqueue.c: In function ‘get_work_pool’:
../kernel/workqueue.c:741:25: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
  741 |                 return ((struct pool_workqueue *)
      |                         ^
../kernel/workqueue.c: In function ‘get_work_pool_id’:
../kernel/workqueue.c:763:25: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
  763 |                 return ((struct pool_workqueue *)
      |                         ^

Fixes: e120153ddf86 ("workqueue: fix how cpu number is stored in work->data")
Fixes: 112202d9098a ("workqueue: rename cpu_workqueue to pool_workqueue")
Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
Cc: Tejun Heo <tj@kernel.org>
Cc: Lai Jiangshan <jiangshanlai@gmail.com>
---
 kernel/workqueue.c |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
  

Comments

Lai Jiangshan May 1, 2023, 4:37 a.m. UTC | #1
On Sat, Apr 29, 2023 at 12:45 PM Randy Dunlap <rdunlap@infradead.org> wrote:
>
> Add casts to avoid int-to-pointer-cast warings on i386 or UML for i386:
>
> ../kernel/workqueue.c: In function ‘get_work_pwq’:
> ../kernel/workqueue.c:713:24: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
>   713 |                 return (void *)(data & WORK_STRUCT_WQ_DATA_MASK);
>       |                        ^
> ../kernel/workqueue.c: In function ‘get_work_pool’:
> ../kernel/workqueue.c:741:25: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
>   741 |                 return ((struct pool_workqueue *)
>       |                         ^
> ../kernel/workqueue.c: In function ‘get_work_pool_id’:
> ../kernel/workqueue.c:763:25: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
>   763 |                 return ((struct pool_workqueue *)
>       |                         ^
>

Hello, Randy

Both the type of the "data" and WORK_STRUCT_WQ_DATA_MASK are
"unsigned long", so I don't think "(data & WORK_STRUCT_WQ_DATA_MASK)"
needs to be converted to "unsigned long".

        WORK_STRUCT_FLAG_MASK   = (1UL << WORK_STRUCT_FLAG_BITS) - 1,
        WORK_STRUCT_WQ_DATA_MASK = ~WORK_STRUCT_FLAG_MASK,

This simple fix might hide the real problem.

Thanks
Lai.

> Fixes: e120153ddf86 ("workqueue: fix how cpu number is stored in work->data")
> Fixes: 112202d9098a ("workqueue: rename cpu_workqueue to pool_workqueue")
> Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
> Cc: Tejun Heo <tj@kernel.org>
> Cc: Lai Jiangshan <jiangshanlai@gmail.com>
> ---
>  kernel/workqueue.c |    6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff -- a/kernel/workqueue.c b/kernel/workqueue.c
> --- a/kernel/workqueue.c
> +++ b/kernel/workqueue.c
> @@ -710,7 +710,7 @@ static struct pool_workqueue *get_work_p
>         unsigned long data = atomic_long_read(&work->data);
>
>         if (data & WORK_STRUCT_PWQ)
> -               return (void *)(data & WORK_STRUCT_WQ_DATA_MASK);
> +               return (void *)(unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK);
>         else
>                 return NULL;
>  }
> @@ -739,7 +739,7 @@ static struct worker_pool *get_work_pool
>
>         if (data & WORK_STRUCT_PWQ)
>                 return ((struct pool_workqueue *)
> -                       (data & WORK_STRUCT_WQ_DATA_MASK))->pool;
> +                       (unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK))->pool;
>
>         pool_id = data >> WORK_OFFQ_POOL_SHIFT;
>         if (pool_id == WORK_OFFQ_POOL_NONE)
> @@ -761,7 +761,7 @@ static int get_work_pool_id(struct work_
>
>         if (data & WORK_STRUCT_PWQ)
>                 return ((struct pool_workqueue *)
> -                       (data & WORK_STRUCT_WQ_DATA_MASK))->pool->id;
> +                       (unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK))->pool->id;
>
>         return data >> WORK_OFFQ_POOL_SHIFT;
>  }
  
Randy Dunlap May 1, 2023, 4:42 a.m. UTC | #2
Hi Lai,

On 4/30/23 21:37, Lai Jiangshan wrote:
> On Sat, Apr 29, 2023 at 12:45 PM Randy Dunlap <rdunlap@infradead.org> wrote:
>>
>> Add casts to avoid int-to-pointer-cast warings on i386 or UML for i386:
>>
>> ../kernel/workqueue.c: In function ‘get_work_pwq’:
>> ../kernel/workqueue.c:713:24: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
>>   713 |                 return (void *)(data & WORK_STRUCT_WQ_DATA_MASK);
>>       |                        ^
>> ../kernel/workqueue.c: In function ‘get_work_pool’:
>> ../kernel/workqueue.c:741:25: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
>>   741 |                 return ((struct pool_workqueue *)
>>       |                         ^
>> ../kernel/workqueue.c: In function ‘get_work_pool_id’:
>> ../kernel/workqueue.c:763:25: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
>>   763 |                 return ((struct pool_workqueue *)
>>       |                         ^
>>
> 
> Hello, Randy
> 
> Both the type of the "data" and WORK_STRUCT_WQ_DATA_MASK are
> "unsigned long", so I don't think "(data & WORK_STRUCT_WQ_DATA_MASK)"
> needs to be converted to "unsigned long".
> 
>         WORK_STRUCT_FLAG_MASK   = (1UL << WORK_STRUCT_FLAG_BITS) - 1,
>         WORK_STRUCT_WQ_DATA_MASK = ~WORK_STRUCT_FLAG_MASK,
> 
> This simple fix might hide the real problem.

Thanks for replying.

Do you have any suggestions for how to eliminate these warnings on i386
and ARCH=um SUBARCH=i386?

> Thanks
> Lai.
> 
>> Fixes: e120153ddf86 ("workqueue: fix how cpu number is stored in work->data")
>> Fixes: 112202d9098a ("workqueue: rename cpu_workqueue to pool_workqueue")
>> Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
>> Cc: Tejun Heo <tj@kernel.org>
>> Cc: Lai Jiangshan <jiangshanlai@gmail.com>
>> ---
>>  kernel/workqueue.c |    6 +++---
>>  1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff -- a/kernel/workqueue.c b/kernel/workqueue.c
>> --- a/kernel/workqueue.c
>> +++ b/kernel/workqueue.c
>> @@ -710,7 +710,7 @@ static struct pool_workqueue *get_work_p
>>         unsigned long data = atomic_long_read(&work->data);
>>
>>         if (data & WORK_STRUCT_PWQ)
>> -               return (void *)(data & WORK_STRUCT_WQ_DATA_MASK);
>> +               return (void *)(unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK);
>>         else
>>                 return NULL;
>>  }
>> @@ -739,7 +739,7 @@ static struct worker_pool *get_work_pool
>>
>>         if (data & WORK_STRUCT_PWQ)
>>                 return ((struct pool_workqueue *)
>> -                       (data & WORK_STRUCT_WQ_DATA_MASK))->pool;
>> +                       (unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK))->pool;
>>
>>         pool_id = data >> WORK_OFFQ_POOL_SHIFT;
>>         if (pool_id == WORK_OFFQ_POOL_NONE)
>> @@ -761,7 +761,7 @@ static int get_work_pool_id(struct work_
>>
>>         if (data & WORK_STRUCT_PWQ)
>>                 return ((struct pool_workqueue *)
>> -                       (data & WORK_STRUCT_WQ_DATA_MASK))->pool->id;
>> +                       (unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK))->pool->id;
>>
>>         return data >> WORK_OFFQ_POOL_SHIFT;
>>  }
  
Arnd Bergmann May 8, 2023, 1:41 p.m. UTC | #3
On Mon, May 1, 2023, at 06:42, Randy Dunlap wrote:
> On 4/30/23 21:37, Lai Jiangshan wrote:
>> Both the type of the "data" and WORK_STRUCT_WQ_DATA_MASK are
>> "unsigned long", so I don't think "(data & WORK_STRUCT_WQ_DATA_MASK)"
>> needs to be converted to "unsigned long".
>> 
>>         WORK_STRUCT_FLAG_MASK   = (1UL << WORK_STRUCT_FLAG_BITS) - 1,
>>         WORK_STRUCT_WQ_DATA_MASK = ~WORK_STRUCT_FLAG_MASK,
>> 
>> This simple fix might hide the real problem.
>
> Thanks for replying.
>
> Do you have any suggestions for how to eliminate these warnings on i386
> and ARCH=um SUBARCH=i386?

I'm pretty sure the patch I posted earlier is the correct one, see
https://lore.kernel.org/all/20230117164041.1207412-1-arnd@kernel.org/

Sorry I never followed up on this after the initial post, I have
a backlog of patches that I sent out as build fixes but that for
some reason have not made it in.

     Arnd
  
Randy Dunlap May 8, 2023, 7:06 p.m. UTC | #4
On 5/8/23 06:41, Arnd Bergmann wrote:
> On Mon, May 1, 2023, at 06:42, Randy Dunlap wrote:
>> On 4/30/23 21:37, Lai Jiangshan wrote:
>>> Both the type of the "data" and WORK_STRUCT_WQ_DATA_MASK are
>>> "unsigned long", so I don't think "(data & WORK_STRUCT_WQ_DATA_MASK)"
>>> needs to be converted to "unsigned long".
>>>
>>>         WORK_STRUCT_FLAG_MASK   = (1UL << WORK_STRUCT_FLAG_BITS) - 1,
>>>         WORK_STRUCT_WQ_DATA_MASK = ~WORK_STRUCT_FLAG_MASK,
>>>
>>> This simple fix might hide the real problem.
>>
>> Thanks for replying.
>>
>> Do you have any suggestions for how to eliminate these warnings on i386
>> and ARCH=um SUBARCH=i386?
> 
> I'm pretty sure the patch I posted earlier is the correct one, see
> https://lore.kernel.org/all/20230117164041.1207412-1-arnd@kernel.org/
> 

Thanks for the reply. Your patch looks good. I appreciate the
explanation.

> Sorry I never followed up on this after the initial post, I have
> a backlog of patches that I sent out as build fixes but that for
> some reason have not made it in.

I know how that goes. I have quite a few as well.
  

Patch

diff -- a/kernel/workqueue.c b/kernel/workqueue.c
--- a/kernel/workqueue.c
+++ b/kernel/workqueue.c
@@ -710,7 +710,7 @@  static struct pool_workqueue *get_work_p
 	unsigned long data = atomic_long_read(&work->data);
 
 	if (data & WORK_STRUCT_PWQ)
-		return (void *)(data & WORK_STRUCT_WQ_DATA_MASK);
+		return (void *)(unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK);
 	else
 		return NULL;
 }
@@ -739,7 +739,7 @@  static struct worker_pool *get_work_pool
 
 	if (data & WORK_STRUCT_PWQ)
 		return ((struct pool_workqueue *)
-			(data & WORK_STRUCT_WQ_DATA_MASK))->pool;
+			(unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK))->pool;
 
 	pool_id = data >> WORK_OFFQ_POOL_SHIFT;
 	if (pool_id == WORK_OFFQ_POOL_NONE)
@@ -761,7 +761,7 @@  static int get_work_pool_id(struct work_
 
 	if (data & WORK_STRUCT_PWQ)
 		return ((struct pool_workqueue *)
-			(data & WORK_STRUCT_WQ_DATA_MASK))->pool->id;
+			(unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK))->pool->id;
 
 	return data >> WORK_OFFQ_POOL_SHIFT;
 }