hwmon: (aquacomputer_d5next) Fix alignment of function call params

Message ID 20230409183549.12683-1-savicaleksa83@gmail.com
State New
Headers
Series hwmon: (aquacomputer_d5next) Fix alignment of function call params |

Commit Message

Aleksa Savic April 9, 2023, 6:35 p.m. UTC
  checkpatch warns that alignment of parameters of function call around
line 869 is off. Indent them properly.

Fixes: 6f5cdf9b9a86 ("hwmon: (aquacomputer_d5next) Add fan PWM control for Aquaero")
Signed-off-by: Aleksa Savic <savicaleksa83@gmail.com>
---
 drivers/hwmon/aquacomputer_d5next.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
  

Comments

Guenter Roeck April 10, 2023, 4:53 p.m. UTC | #1
On Sun, Apr 09, 2023 at 08:35:49PM +0200, Aleksa Savic wrote:
> checkpatch warns that alignment of parameters of function call around
> line 869 is off. Indent them properly.
> 
> Fixes: 6f5cdf9b9a86 ("hwmon: (aquacomputer_d5next) Add fan PWM control for Aquaero")
> Signed-off-by: Aleksa Savic <savicaleksa83@gmail.com>
> ---
>  drivers/hwmon/aquacomputer_d5next.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/hwmon/aquacomputer_d5next.c b/drivers/hwmon/aquacomputer_d5next.c
> index 3bd35d833e69..7db7769fe044 100644
> --- a/drivers/hwmon/aquacomputer_d5next.c
> +++ b/drivers/hwmon/aquacomputer_d5next.c
> @@ -867,8 +867,8 @@ static int aqc_read(struct device *dev, enum hwmon_sensor_types type, u32 attr,
>  		switch (priv->kind) {
>  		case aquaero:
>  			ret = aqc_get_ctrl_val(priv,
> -				AQUAERO_CTRL_PRESET_START + channel * AQUAERO_CTRL_PRESET_SIZE,
> -				val, AQC_BE16);
> +					       AQUAERO_CTRL_PRESET_START +
> +					       channel * AQUAERO_CTRL_PRESET_SIZE, val, AQC_BE16);

I am not sure I understand how this would improve readability.
It seems to accomplish the opposite. Sure, I know, checkpatch --strict
complains, but that is still better than unreadable code just to make
checkpatch happy.

Guenter
  
Aleksa Savic April 11, 2023, 6:26 p.m. UTC | #2
On 2023-04-10 18:53:08 GMT+02:00, Guenter Roeck wrote:
> 
> I am not sure I understand how this would improve readability.
> It seems to accomplish the opposite. Sure, I know, checkpatch --strict
> complains, but that is still better than unreadable code just to make
> checkpatch happy.
> 
> Guenter

Both seemed fine to me, the idea was to fix the checkpatch warning.
If it's OK for it to complain about this, plus the changes would make it
harder to read, please ignore this patch.

Thanks,
Aleksa
  
Guenter Roeck April 11, 2023, 8:19 p.m. UTC | #3
On Tue, Apr 11, 2023 at 08:26:32PM +0200, Aleksa Savic wrote:
> On 2023-04-10 18:53:08 GMT+02:00, Guenter Roeck wrote:
> > 
> > I am not sure I understand how this would improve readability.
> > It seems to accomplish the opposite. Sure, I know, checkpatch --strict
> > complains, but that is still better than unreadable code just to make
> > checkpatch happy.
> > 
> > Guenter
> 
> Both seemed fine to me, the idea was to fix the checkpatch warning.
> If it's OK for it to complain about this, plus the changes would make it
> harder to read, please ignore this patch.
> 

checkpatch is useful, but not in situations where following its guidance
results in code which is diffficult to read. I run checkpatch --strict when
applying patches, so I do notice when it complains. If I want a report
to be addressed, I'll say that (such as, for example, when people are
overly generous with empty lines). If not, you can assume that I am ok with
the report and find it more important to have readable code than being
checkpatch-clean.

Guenter
  
Aleksa Savic April 12, 2023, 5:18 a.m. UTC | #4
On 2023-04-11 22:19:21 GMT+02:00, Guenter Roeck wrote:
> On Tue, Apr 11, 2023 at 08:26:32PM +0200, Aleksa Savic wrote:
>> On 2023-04-10 18:53:08 GMT+02:00, Guenter Roeck wrote:
>>>
>>> I am not sure I understand how this would improve readability.
>>> It seems to accomplish the opposite. Sure, I know, checkpatch --strict
>>> complains, but that is still better than unreadable code just to make
>>> checkpatch happy.
>>>
>>> Guenter
>>
>> Both seemed fine to me, the idea was to fix the checkpatch warning.
>> If it's OK for it to complain about this, plus the changes would make it
>> harder to read, please ignore this patch.
>>
> 
> checkpatch is useful, but not in situations where following its guidance
> results in code which is diffficult to read. I run checkpatch --strict when
> applying patches, so I do notice when it complains. If I want a report
> to be addressed, I'll say that (such as, for example, when people are
> overly generous with empty lines). If not, you can assume that I am ok with
> the report and find it more important to have readable code than being
> checkpatch-clean.
> 
> Guenter

That clears it up, thanks!

Aleksa
  

Patch

diff --git a/drivers/hwmon/aquacomputer_d5next.c b/drivers/hwmon/aquacomputer_d5next.c
index 3bd35d833e69..7db7769fe044 100644
--- a/drivers/hwmon/aquacomputer_d5next.c
+++ b/drivers/hwmon/aquacomputer_d5next.c
@@ -867,8 +867,8 @@  static int aqc_read(struct device *dev, enum hwmon_sensor_types type, u32 attr,
 		switch (priv->kind) {
 		case aquaero:
 			ret = aqc_get_ctrl_val(priv,
-				AQUAERO_CTRL_PRESET_START + channel * AQUAERO_CTRL_PRESET_SIZE,
-				val, AQC_BE16);
+					       AQUAERO_CTRL_PRESET_START +
+					       channel * AQUAERO_CTRL_PRESET_SIZE, val, AQC_BE16);
 			if (ret < 0)
 				return ret;
 			*val = aqc_percent_to_pwm(*val);