[3/8] of: Create an of_device_request_module() receiving an OF node

Message ID 20230301152239.531194-4-miquel.raynal@bootlin.com
State New
Headers
Series nvmem: Let layout drivers be modules |

Commit Message

Miquel Raynal March 1, 2023, 3:22 p.m. UTC
  of_device_request_module() currently receives a "struct device" as main
argument, but the only use of this pointer is to access its .of_node
member. In practice, this function only needs a "struct
device_node". Let's move the logic into another helper which would
receive a "struct device_node" instead, and use that new helper from the
ancient of_device_request_module(). Exporting this new function will be
useful to request module loading when the "struct device" is not
available.

Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>
---
 drivers/of/device.c       | 17 +++++++++++++----
 include/linux/of_device.h |  6 ++++++
 2 files changed, 19 insertions(+), 4 deletions(-)
  

Comments

Rob Herring March 2, 2023, 7:13 p.m. UTC | #1
On Wed, Mar 1, 2023 at 9:22 AM Miquel Raynal <miquel.raynal@bootlin.com> wrote:
>
> of_device_request_module() currently receives a "struct device" as main
> argument, but the only use of this pointer is to access its .of_node
> member. In practice, this function only needs a "struct
> device_node". Let's move the logic into another helper which would
> receive a "struct device_node" instead, and use that new helper from the
> ancient of_device_request_module(). Exporting this new function will be
> useful to request module loading when the "struct device" is not
> available.

of_device.h is for things that operate on struct device, so
of_device_request_module() doesn't really belong here.

I wouldn't really care, but we have this ~12 year old line in of_device.h:

#include <linux/of_platform.h> /* temporary until merge */

I started working on a very churny series to fix this only to wonder
if a header split by consumer would be better. Anyways, concrete
suggestions below...

> Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>
> ---
>  drivers/of/device.c       | 17 +++++++++++++----
>  include/linux/of_device.h |  6 ++++++
>  2 files changed, 19 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/of/device.c b/drivers/of/device.c
> index 3efc17de1d57..7cdf252b9526 100644
> --- a/drivers/of/device.c
> +++ b/drivers/of/device.c
> @@ -284,16 +284,16 @@ static ssize_t of_device_get_modalias(struct device_node *np, char *str, ssize_t
>         return tsize;
>  }
>
> -int of_device_request_module(struct device *dev)
> +int of_device_node_request_module(struct device_node *np)'

We use 'device_node' pretty much nowhere in the DT APIs. Just
of_request_module() and define in of.h. There is only one user of
of_device_request_module, so remove it and update the user to use
of_request_module() (and hopefully drop of_device.h for it).

Rob
  

Patch

diff --git a/drivers/of/device.c b/drivers/of/device.c
index 3efc17de1d57..7cdf252b9526 100644
--- a/drivers/of/device.c
+++ b/drivers/of/device.c
@@ -284,16 +284,16 @@  static ssize_t of_device_get_modalias(struct device_node *np, char *str, ssize_t
 	return tsize;
 }
 
-int of_device_request_module(struct device *dev)
+int of_device_node_request_module(struct device_node *np)
 {
 	char *str;
 	ssize_t size;
 	int ret;
 
-	if (!dev || !dev->of_node)
+	if (!np)
 		return -ENODEV;
 
-	size = of_device_get_modalias(dev->of_node, NULL, 0);
+	size = of_device_get_modalias(np, NULL, 0);
 	if (size < 0)
 		return size;
 
@@ -304,13 +304,22 @@  int of_device_request_module(struct device *dev)
 	if (!str)
 		return -ENOMEM;
 
-	of_device_get_modalias(dev->of_node, str, size);
+	of_device_get_modalias(np, str, size);
 	str[size - 1] = '\0';
 	ret = request_module(str);
 	kfree(str);
 
 	return ret;
 }
+EXPORT_SYMBOL_GPL(of_device_node_request_module);
+
+int of_device_request_module(struct device *dev)
+{
+	if (!dev)
+		return -ENODEV;
+
+	return of_device_node_request_module(dev->of_node);
+}
 EXPORT_SYMBOL_GPL(of_device_request_module);
 
 /**
diff --git a/include/linux/of_device.h b/include/linux/of_device.h
index ab7d557d541d..8918f9071ffb 100644
--- a/include/linux/of_device.h
+++ b/include/linux/of_device.h
@@ -33,6 +33,7 @@  extern void of_device_unregister(struct platform_device *ofdev);
 extern const void *of_device_get_match_data(const struct device *dev);
 
 extern ssize_t of_device_modalias(struct device *dev, char *str, ssize_t len);
+extern int of_device_node_request_module(struct device_node *np);
 extern int of_device_request_module(struct device *dev);
 
 extern void of_device_uevent(const struct device *dev, struct kobj_uevent_env *env);
@@ -78,6 +79,11 @@  static inline int of_device_modalias(struct device *dev,
 	return -ENODEV;
 }
 
+static inline int of_device_node_request_module(struct device_node *np)
+{
+	return -ENODEV;
+}
+
 static inline int of_device_request_module(struct device *dev)
 {
 	return -ENODEV;