[-next] irqchip: orion: use of_address_count() helper

Message ID 20221027071614.1462397-1-yangyingliang@huawei.com
State New
Headers
Series [-next] irqchip: orion: use of_address_count() helper |

Commit Message

Yang Yingliang Oct. 27, 2022, 7:16 a.m. UTC
  After commit 16988c742968 ("of/address: introduce of_address_count() helper"),
Use of_address_count() to instead of open-coding it, it's no functional change.

Signed-off-by: Yang Yingliang <yangyingliang@huawei.com>
---
 drivers/irqchip/irq-orion.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
  

Comments

Marc Zyngier Oct. 27, 2022, 8:56 a.m. UTC | #1
On Thu, 27 Oct 2022 08:16:14 +0100,
Yang Yingliang <yangyingliang@huawei.com> wrote:
> 
> After commit 16988c742968 ("of/address: introduce of_address_count() helper"),
> Use of_address_count() to instead of open-coding it, it's no functional change.

$ git grep of_address_count| wc -l
0

Sorry, but I'm not taking patches for stuff that isn't in Linus'
tree. This sort of changes should be part of a series. Consider
reposting this once we reach 6.2-rc1.

	M.
  

Patch

diff --git a/drivers/irqchip/irq-orion.c b/drivers/irqchip/irq-orion.c
index 17c2c7a07f10..4e4e874e09a8 100644
--- a/drivers/irqchip/irq-orion.c
+++ b/drivers/irqchip/irq-orion.c
@@ -57,8 +57,7 @@  static int __init orion_irq_init(struct device_node *np,
 	struct resource r;
 
 	/* count number of irq chips by valid reg addresses */
-	while (of_address_to_resource(np, num_chips, &r) == 0)
-		num_chips++;
+	num_chips = of_address_count(np);
 
 	orion_irq_domain = irq_domain_add_linear(np,
 				num_chips * ORION_IRQS_PER_CHIP,