[GIT,PULL] extcon next for 6.4

Message ID 1d2b9fd2-4a59-cb3b-2fd3-9f6635f3bbf8@gmail.com
State New
Headers
Series [GIT,PULL] extcon next for 6.4 |

Pull-request

git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git tags/extcon-next-for-6.4

Message

Chanwoo Choi April 16, 2023, 3:28 p.m. UTC
  Dear Greg,

This is extcon-next pull request for v6.4. I add detailed description of
this pull request on below. Please pull extcon with following updates.

Best Regards,
Chanwoo Choi


The following changes since commit 09a9639e56c01c7a00d6c0ca63f4c7c41abe075d:

  Linux 6.3-rc6 (2023-04-09 11:15:57 -0700)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git tags/extcon-next-for-6.4

for you to fetch changes up to 4e30418def07f8359c7927d5815788043afbb482:

  extcon: Drop unneeded assignments (2023-04-17 00:14:12 +0900)

----------------------------------------------------------------
Update extcon next for v6.4

Detailed description for this pull request:
1. Clean-up extcon core without any behavior changes
- Add extcon_alloc_cables/muex/groups to improve the readability
  of extcon_dev_register.

- Fix kernel doc of property and property capability fields to aovid warnings
  and add missing description of struct extcon_dev.

- Use DECLARE_BITMAP macro and sysfs_emit instead of sprintf

- Use device_match_of_node helper instead of accessing the .of_node

- Use ida_alloc/free to get the unique id for extcon device

2. Update extcon-usbc-tusb320.c to support usb_role_switch and accessory detection
- Add usb_role_switch support on extcon-usbsc-tusb320.

- Add additional accessory detection for audio/debug accessory
  and then pass the deteced accessory information to typec subsystem
  on extcon-usbsc-tusb320.c.

- Add the support of unregistration of typec port on both error handling
  and driver removal step on

3. Update extcon provider drivers (apx288/qcom-spmi-misc/palmas)
- Replace put_device with acpi_dev_put on extcon-axp288.c

- Use platform_get_irq_byname_optional for getting irq of
  usb_id and usb_vbus on extcon-qcom-spmi-misc.c.

- Remove unused of_gpio.h on extcon-palmas.c.

4. Fix the devicetree binding document
- Rename misc node name to 'usb-dect@900' on pm8941-misc.yam

- Fix usb-id and usb_vbus defintion on pm8941-misc.yaml
----------------------------------------------------------------

Alvin Šipraga (3):
      extcon: usbc-tusb320: Unregister typec port on driver removal
      extcon: usbc-tusb320: add accessory detection support
      extcon: usbc-tusb320: add usb_role_switch support

Andy Shevchenko (13):
      extcon: axp288: Replace open coded acpi_dev_put()
      extcon: palmas: Remove unused of_gpio.h
      extcon: Fix kernel doc of property fields to avoid warnings
      extcon: Fix kernel doc of property capability fields to avoid warnings
      extcon: Use DECLARE_BITMAP() to declare bit arrays
      extcon: Use sysfs_emit() to instead of sprintf()
      extcon: Amend kernel documentation of struct extcon_dev
      extcon: Use device_match_of_node() helper
      extcon: Use dev_of_node(dev) instead of dev->of_node
      extcon: Remove dup device name in the message and unneeded error check
      extcon: Use unique number for the extcon device ID
      extcon: Use sizeof(*pointer) instead of sizeof(type)
      extcon: Drop unneeded assignments

Arnd Bergmann (1):
      extcon: usbc-tusb320: add USB_ROLE_SWITCH dependency

Bryan O'Donoghue (2):
      dt-bindings: pm8941-misc: Fix usb_id and usb_vbus definitions
      extcon: qcom-spmi: Switch to platform_get_irq_byname_optional

Bumwoo Lee (4):
      extcon: Remove redundant null checking for class
      extcon: Add extcon_alloc_cables to simplify extcon register function
      extcon: Add extcon_alloc_muex to simplify extcon register function
      extcon: Add extcon_alloc_groups to simplify extcon register function

Luca Weiss (1):
      dt-bindings: pm8941-misc: rename misc node name

 .../bindings/extcon/qcom,pm8941-misc.yaml          |  14 +-
 drivers/extcon/Kconfig                             |   1 +
 drivers/extcon/extcon-axp288.c                     |   2 +-
 drivers/extcon/extcon-palmas.c                     |   1 -
 drivers/extcon/extcon-qcom-spmi-misc.c             |   4 +-
 drivers/extcon/extcon-usbc-tusb320.c               | 153 +++++++--
 drivers/extcon/extcon.c                            | 368 ++++++++++++---------
 drivers/extcon/extcon.h                            |   8 +-
 8 files changed, 354 insertions(+), 197 deletions(-)
  

Comments

Chanwoo Choi April 25, 2023, 12:58 p.m. UTC | #1
Dear Greg,

Gently ping for v6.4.

Best Regards,
Chanwoo Choi

On 23. 4. 17. 00:28, Chanwoo Choi wrote:
> Dear Greg,
> 
> This is extcon-next pull request for v6.4. I add detailed description of
> this pull request on below. Please pull extcon with following updates.
> 
> Best Regards,
> Chanwoo Choi
> 
> 
> The following changes since commit 09a9639e56c01c7a00d6c0ca63f4c7c41abe075d:
> 
>   Linux 6.3-rc6 (2023-04-09 11:15:57 -0700)
> 
> are available in the Git repository at:
> 
>   git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git tags/extcon-next-for-6.4
> 
> for you to fetch changes up to 4e30418def07f8359c7927d5815788043afbb482:
> 
>   extcon: Drop unneeded assignments (2023-04-17 00:14:12 +0900)
> 
> ----------------------------------------------------------------
> Update extcon next for v6.4
> 
> Detailed description for this pull request:
> 1. Clean-up extcon core without any behavior changes
> - Add extcon_alloc_cables/muex/groups to improve the readability
>   of extcon_dev_register.
> 
> - Fix kernel doc of property and property capability fields to aovid warnings
>   and add missing description of struct extcon_dev.
> 
> - Use DECLARE_BITMAP macro and sysfs_emit instead of sprintf
> 
> - Use device_match_of_node helper instead of accessing the .of_node
> 
> - Use ida_alloc/free to get the unique id for extcon device
> 
> 2. Update extcon-usbc-tusb320.c to support usb_role_switch and accessory detection
> - Add usb_role_switch support on extcon-usbsc-tusb320.
> 
> - Add additional accessory detection for audio/debug accessory
>   and then pass the deteced accessory information to typec subsystem
>   on extcon-usbsc-tusb320.c.
> 
> - Add the support of unregistration of typec port on both error handling
>   and driver removal step on
> 
> 3. Update extcon provider drivers (apx288/qcom-spmi-misc/palmas)
> - Replace put_device with acpi_dev_put on extcon-axp288.c
> 
> - Use platform_get_irq_byname_optional for getting irq of
>   usb_id and usb_vbus on extcon-qcom-spmi-misc.c.
> 
> - Remove unused of_gpio.h on extcon-palmas.c.
> 
> 4. Fix the devicetree binding document
> - Rename misc node name to 'usb-dect@900' on pm8941-misc.yam
> 
> - Fix usb-id and usb_vbus defintion on pm8941-misc.yaml
> ----------------------------------------------------------------
> 
> Alvin Šipraga (3):
>       extcon: usbc-tusb320: Unregister typec port on driver removal
>       extcon: usbc-tusb320: add accessory detection support
>       extcon: usbc-tusb320: add usb_role_switch support
> 
> Andy Shevchenko (13):
>       extcon: axp288: Replace open coded acpi_dev_put()
>       extcon: palmas: Remove unused of_gpio.h
>       extcon: Fix kernel doc of property fields to avoid warnings
>       extcon: Fix kernel doc of property capability fields to avoid warnings
>       extcon: Use DECLARE_BITMAP() to declare bit arrays
>       extcon: Use sysfs_emit() to instead of sprintf()
>       extcon: Amend kernel documentation of struct extcon_dev
>       extcon: Use device_match_of_node() helper
>       extcon: Use dev_of_node(dev) instead of dev->of_node
>       extcon: Remove dup device name in the message and unneeded error check
>       extcon: Use unique number for the extcon device ID
>       extcon: Use sizeof(*pointer) instead of sizeof(type)
>       extcon: Drop unneeded assignments
> 
> Arnd Bergmann (1):
>       extcon: usbc-tusb320: add USB_ROLE_SWITCH dependency
> 
> Bryan O'Donoghue (2):
>       dt-bindings: pm8941-misc: Fix usb_id and usb_vbus definitions
>       extcon: qcom-spmi: Switch to platform_get_irq_byname_optional
> 
> Bumwoo Lee (4):
>       extcon: Remove redundant null checking for class
>       extcon: Add extcon_alloc_cables to simplify extcon register function
>       extcon: Add extcon_alloc_muex to simplify extcon register function
>       extcon: Add extcon_alloc_groups to simplify extcon register function
> 
> Luca Weiss (1):
>       dt-bindings: pm8941-misc: rename misc node name
> 
>  .../bindings/extcon/qcom,pm8941-misc.yaml          |  14 +-
>  drivers/extcon/Kconfig                             |   1 +
>  drivers/extcon/extcon-axp288.c                     |   2 +-
>  drivers/extcon/extcon-palmas.c                     |   1 -
>  drivers/extcon/extcon-qcom-spmi-misc.c             |   4 +-
>  drivers/extcon/extcon-usbc-tusb320.c               | 153 +++++++--
>  drivers/extcon/extcon.c                            | 368 ++++++++++++---------
>  drivers/extcon/extcon.h                            |   8 +-
>  8 files changed, 354 insertions(+), 197 deletions(-)
  
Greg KH April 25, 2023, 1:22 p.m. UTC | #2
On Tue, Apr 25, 2023 at 09:58:47PM +0900, Chanwoo Choi wrote:
> Dear Greg,
> 
> Gently ping for v6.4.

Ouch, something went wrong with your first email and it ended up in my
spam folder in gmail, so sorry about that :(

Is your tree included in linux-next already?

thanks,

greg k-h
  
Chanwoo Choi April 25, 2023, 6:49 p.m. UTC | #3
Dear Greg,

On 23. 4. 25. 22:22, Greg Kroah-Hartman wrote:
> On Tue, Apr 25, 2023 at 09:58:47PM +0900, Chanwoo Choi wrote:
>> Dear Greg,
>>
>> Gently ping for v6.4.
> 
> Ouch, something went wrong with your first email and it ended up in my
> spam folder in gmail, so sorry about that :(

I'm sorry. I'll use the @kernel.org account on next time.


> 
> Is your tree included in linux-next already?
> 

Yes. extcon.git was included in linux-next.

And my pull request edited the 'class_create()'
Thus, it might have a conflict as following report[1] from Stetphen Rothwell (linux-next.git).
[1] https://lore.kernel.org/lkml/ZBhOTW9v9jzJVY7e@kroah.com/
  
Greg KH April 27, 2023, 2:22 p.m. UTC | #4
On Wed, Apr 26, 2023 at 03:49:17AM +0900, Chanwoo Choi wrote:
> Dear Greg,
> 
> On 23. 4. 25. 22:22, Greg Kroah-Hartman wrote:
> > On Tue, Apr 25, 2023 at 09:58:47PM +0900, Chanwoo Choi wrote:
> >> Dear Greg,
> >>
> >> Gently ping for v6.4.
> > 
> > Ouch, something went wrong with your first email and it ended up in my
> > spam folder in gmail, so sorry about that :(
> 
> I'm sorry. I'll use the @kernel.org account on next time.
> 
> 
> > 
> > Is your tree included in linux-next already?
> > 
> 
> Yes. extcon.git was included in linux-next.
> 
> And my pull request edited the 'class_create()'
> Thus, it might have a conflict as following report[1] from Stetphen Rothwell (linux-next.git).
> [1] https://lore.kernel.org/lkml/ZBhOTW9v9jzJVY7e@kroah.com/

Ok, I've sent off my pull request to Linus now.  Let's get that merged
and then I'll take this one and get the class_create() fix in as well.

thanks,

greg k-h
  
Greg KH April 28, 2023, 6:12 a.m. UTC | #5
On Wed, Apr 26, 2023 at 03:49:17AM +0900, Chanwoo Choi wrote:
> Dear Greg,
> 
> On 23. 4. 25. 22:22, Greg Kroah-Hartman wrote:
> > On Tue, Apr 25, 2023 at 09:58:47PM +0900, Chanwoo Choi wrote:
> >> Dear Greg,
> >>
> >> Gently ping for v6.4.
> > 
> > Ouch, something went wrong with your first email and it ended up in my
> > spam folder in gmail, so sorry about that :(
> 
> I'm sorry. I'll use the @kernel.org account on next time.
> 
> 
> > 
> > Is your tree included in linux-next already?
> > 
> 
> Yes. extcon.git was included in linux-next.
> 
> And my pull request edited the 'class_create()'
> Thus, it might have a conflict as following report[1] from Stetphen Rothwell (linux-next.git).
> [1] https://lore.kernel.org/lkml/ZBhOTW9v9jzJVY7e@kroah.com/

Ok, I tried to pull this today, but I get the following error:

Commit: 40f9fc3c2b38 ("extcon: usbc-tusb320: add USB_ROLE_SWITCH dependency")
	Fixes tag: Fixes: 19685ae43489 ("extcon: usbc-tusb320: add usb_role_switch support")
	Has these problem(s):
		- Target SHA1 does not exist

Are you sure that linux-next actually passed this tree?

All of these were added to your tree only 12 days ago.  Perhaps we should just
wait until 6.5-rc1 for the new features, and take the bug fixes now?  Can you
redo this to make it so I can take the bugfixes after 6.4-rc1 is out, and throw
away this tree for now?

thanks,

greg k-h
  
Chanwoo Choi April 30, 2023, 12:29 a.m. UTC | #6
On 23. 4. 28. 15:12, Greg Kroah-Hartman wrote:
> On Wed, Apr 26, 2023 at 03:49:17AM +0900, Chanwoo Choi wrote:
>> Dear Greg,
>>
>> On 23. 4. 25. 22:22, Greg Kroah-Hartman wrote:
>>> On Tue, Apr 25, 2023 at 09:58:47PM +0900, Chanwoo Choi wrote:
>>>> Dear Greg,
>>>>
>>>> Gently ping for v6.4.
>>>
>>> Ouch, something went wrong with your first email and it ended up in my
>>> spam folder in gmail, so sorry about that :(
>>
>> I'm sorry. I'll use the @kernel.org account on next time.
>>
>>
>>>
>>> Is your tree included in linux-next already?
>>>
>>
>> Yes. extcon.git was included in linux-next.
>>
>> And my pull request edited the 'class_create()'
>> Thus, it might have a conflict as following report[1] from Stetphen Rothwell (linux-next.git).
>> [1] https://lore.kernel.org/lkml/ZBhOTW9v9jzJVY7e@kroah.com/
> 
> Ok, I tried to pull this today, but I get the following error:
> 
> Commit: 40f9fc3c2b38 ("extcon: usbc-tusb320: add USB_ROLE_SWITCH dependency")
> 	Fixes tag: Fixes: 19685ae43489 ("extcon: usbc-tusb320: add usb_role_switch support")
> 	Has these problem(s):
> 		- Target SHA1 does not exist
> 
> Are you sure that linux-next actually passed this tree?
> 
> All of these were added to your tree only 12 days ago.  Perhaps we should just
> wait until 6.5-rc1 for the new features, and take the bug fixes now?  Can you
> redo this to make it so I can take the bugfixes after 6.4-rc1 is out, and throw
> away this tree for now?

Dear Greg,

I'm so sorry for my fault. I rebased extcon-next tree based on char-misc.git(v6.3-rc6)
right before sending the pull request. It it the reason to be changed of the commit id.

I'll fix issue and then send the pull request for 6.5-rc1 on later. I'll not rebase
the extcon branch before sending the pull request and use the kernel.org email.

Once again, I'm sorry to bother you.
  
Greg KH April 30, 2023, 8 a.m. UTC | #7
On Sun, Apr 30, 2023 at 09:29:39AM +0900, Chanwoo Choi wrote:
> On 23. 4. 28. 15:12, Greg Kroah-Hartman wrote:
> > On Wed, Apr 26, 2023 at 03:49:17AM +0900, Chanwoo Choi wrote:
> >> Dear Greg,
> >>
> >> On 23. 4. 25. 22:22, Greg Kroah-Hartman wrote:
> >>> On Tue, Apr 25, 2023 at 09:58:47PM +0900, Chanwoo Choi wrote:
> >>>> Dear Greg,
> >>>>
> >>>> Gently ping for v6.4.
> >>>
> >>> Ouch, something went wrong with your first email and it ended up in my
> >>> spam folder in gmail, so sorry about that :(
> >>
> >> I'm sorry. I'll use the @kernel.org account on next time.
> >>
> >>
> >>>
> >>> Is your tree included in linux-next already?
> >>>
> >>
> >> Yes. extcon.git was included in linux-next.
> >>
> >> And my pull request edited the 'class_create()'
> >> Thus, it might have a conflict as following report[1] from Stetphen Rothwell (linux-next.git).
> >> [1] https://lore.kernel.org/lkml/ZBhOTW9v9jzJVY7e@kroah.com/
> > 
> > Ok, I tried to pull this today, but I get the following error:
> > 
> > Commit: 40f9fc3c2b38 ("extcon: usbc-tusb320: add USB_ROLE_SWITCH dependency")
> > 	Fixes tag: Fixes: 19685ae43489 ("extcon: usbc-tusb320: add usb_role_switch support")
> > 	Has these problem(s):
> > 		- Target SHA1 does not exist
> > 
> > Are you sure that linux-next actually passed this tree?
> > 
> > All of these were added to your tree only 12 days ago.  Perhaps we should just
> > wait until 6.5-rc1 for the new features, and take the bug fixes now?  Can you
> > redo this to make it so I can take the bugfixes after 6.4-rc1 is out, and throw
> > away this tree for now?
> 
> Dear Greg,
> 
> I'm so sorry for my fault. I rebased extcon-next tree based on char-misc.git(v6.3-rc6)
> right before sending the pull request. It it the reason to be changed of the commit id.

Please don't rebase unless you really really have a good reason to.
It's almost never needed.

> I'll fix issue and then send the pull request for 6.5-rc1 on later. I'll not rebase
> the extcon branch before sending the pull request and use the kernel.org email.

Great, that should work, thanks.

greg k-h