[v4,0/7] iommu: Retire bus ops

Message ID cover.1696253096.git.robin.murphy@arm.com
Headers
Series iommu: Retire bus ops |

Message

Robin Murphy Oct. 2, 2023, 1:49 p.m. UTC
  v3: https://lore.kernel.org/linux-iommu/cover.1694693889.git.robin.murphy@arm.com/

Hi all,

This one really is hopefully ready to go now - rebased on iommu/core,
and lightly tested by booting a machine with SMMUv3 and running the
IOMMUFD selftest for good measure (with the usual handful of mmap()
failures I always seem to get, but nothing relevant exploded).

Thanks,
Robin.


Robin Murphy (7):
  iommu: Factor out some helpers
  iommu: Decouple iommu_present() from bus ops
  iommu: Validate that devices match domains
  iommu: Switch __iommu_domain_alloc() to device ops
  iommu/arm-smmu: Don't register fwnode for legacy binding
  iommu: Retire bus ops
  iommu: Clean up open-coded ownership checks

 drivers/iommu/arm/arm-smmu-v3/arm-smmu-v3.c |   3 -
 drivers/iommu/arm/arm-smmu/arm-smmu.c       |  12 +-
 drivers/iommu/arm/arm-smmu/qcom_iommu.c     |  16 +-
 drivers/iommu/iommu.c                       | 162 +++++++++++++-------
 drivers/iommu/mtk_iommu.c                   |   7 +-
 drivers/iommu/mtk_iommu_v1.c                |   3 -
 drivers/iommu/sprd-iommu.c                  |   8 +-
 drivers/iommu/virtio-iommu.c                |   3 -
 include/acpi/acpi_bus.h                     |   2 +
 include/linux/device.h                      |   1 -
 include/linux/device/bus.h                  |   5 -
 include/linux/dma-map-ops.h                 |   1 +
 include/linux/iommu.h                       |   1 +
 13 files changed, 115 insertions(+), 109 deletions(-)
  

Comments

Robin Murphy Oct. 2, 2023, 2:32 p.m. UTC | #1
On 02/10/2023 3:17 pm, Jason Gunthorpe wrote:
> On Mon, Oct 02, 2023 at 02:49:10PM +0100, Robin Murphy wrote:
>> Much as I'd like to remove iommu_present(), the final remaining users
>> are proving stubbornly difficult to clean up, so kick that can down the
>> road and just rework it to preserve the current behaviour without
>> depending on bus ops. Since commit 57365a04c921 ("iommu: Move bus setup
>> to IOMMU device registration"), any registered IOMMU instance is already
>> considered "present" for every entry in iommu_buses, so it's simply a
>> case of validating the bus and checking we have at least once IOMMU.
>>
>> Signed-off-by: Robin Murphy <robin.murphy@arm.com>
>>
>> ---
>>
>> v3: Tweak to use the ops-based check rather than group-based, to
>>      properly match the existing behaviour
>> v4: Just look for IOMMU instances instead of managed devices
>> ---
>>   drivers/iommu/iommu.c | 21 ++++++++++++++++++++-
>>   1 file changed, 20 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
>> index f7793d1b5c3e..ef7feb0acc34 100644
>> --- a/drivers/iommu/iommu.c
>> +++ b/drivers/iommu/iommu.c
>> @@ -1988,9 +1988,28 @@ int bus_iommu_probe(const struct bus_type *bus)
>>   	return 0;
>>   }
>>   
>> +/**
>> + * iommu_present() - make platform-specific assumptions about an IOMMU
>> + * @bus: bus to check
>> + *
>> + * Do not use this function. You want device_iommu_mapped() instead.
>> + *
>> + * Return: true if some IOMMU is present and aware of devices on the given bus;
>> + * in general it may not be the only IOMMU, and it may not have anything to do
>> + * with whatever device you are ultimately interested in.
>> + */
>>   bool iommu_present(const struct bus_type *bus)
>>   {
>> -	return bus->iommu_ops != NULL;
>> +	bool ret = false;
>> +
>> +	for (int i = 0; i < ARRAY_SIZE(iommu_buses); i++) {
>> +		if (iommu_buses[i] == bus) {
>> +			spin_lock(&iommu_device_lock);
>> +			ret = !list_empty(&iommu_device_list);
>> +			spin_unlock(&iommu_device_lock);
>> +		}
> 
> Add here:
> 
> return ret;
> 
>> +	}
>> +	return ret;
> 
> And this becomes
> 
> return false
> 
> ?

My aim here was for the smallest, simplest code, given that what we 
still really want is no code, and this is basically only being retained 
to serve that one tricky Tegra callsite. I guess I could have also added 
"&& !ret" to the loop condition, but either way since this should never 
be on a hot path I figured it's not worth the bother just to save a 
handful of extra comparisons.

> Regardless
> 
> Reviewed-by: Jason Gunthorpe <jgg@nvidia.com>

Thanks!

Robin.