[net-next,v4,00/13] net: phy: at803x: cleanup

Message ID 20231208145200.25162-1-ansuelsmth@gmail.com
Headers
Series net: phy: at803x: cleanup |

Message

Christian Marangi Dec. 8, 2023, 2:51 p.m. UTC
  The intention of this big series is to try to cleanup the big
at803x PHY driver.

It currently have 3 different family of PHY in it. at803x, qca83xx
and qca808x.

The current codebase required lots of cleanup and reworking to
make the split possible as currently there is a greater use of
adding special function matching the phy_id.

This has been reworked to make the function actually generic
and make the change only in more specific one. The result
is the addition of micro additional function but that is for good
as it massively simplify splitting the driver later.

Consider that this is all in preparation for the addition of
qca807x PHY driver that will also uso some of the functions of
at803x.

Subsequent series will come with the actual PHY split and other
required cleanup. This is only to start the process with minor
changes.

Changes v4:
- Improve at8031_probe function 
Changes v3:
- Add Reviewed-by tag from Andrew
- Split patch 10 (at8031 rename) to rename and move
Changes v2:
- Drop split part due to series too big
- Split changes even more
- Fix problem pointed out by Russell (flawed reworked function logic)
- Add Reviewed-by tag from Andrew
- Minor rework to prevent further code duplication for cdt

Christian Marangi (13):
  net: phy: at803x: fix passing the wrong reference for config_intr
  net: phy: at803x: move disable WOL to specific at8031 probe
  net: phy: at803x: raname hw_stats functions to qca83xx specific name
  net: phy: at803x: move qca83xx specific check in dedicated functions
  net: phy: at803x: move specific DT option for at8031 to specific probe
  net: phy: at803x: move specific at8031 probe mode check to dedicated
    probe
  net: phy: at803x: move specific at8031 config_init to dedicated
    function
  net: phy: at803x: move specific at8031 WOL bits to dedicated function
  net: phy: at803x: move specific at8031 config_intr to dedicated
    function
  net: phy: at803x: make at8031 related DT functions name more specific
  net: phy: at803x: move at8031 functions in dedicated section
  net: phy: at803x: move at8035 specific DT parse to dedicated probe
  net: phy: at803x: drop specific PHY ID check from cable test functions

 drivers/net/phy/at803x.c | 775 +++++++++++++++++++++------------------
 1 file changed, 426 insertions(+), 349 deletions(-)
  

Comments

patchwork-bot+netdevbpf@kernel.org Dec. 13, 2023, 10:40 a.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (main)
by David S. Miller <davem@davemloft.net>:

On Fri,  8 Dec 2023 15:51:47 +0100 you wrote:
> The intention of this big series is to try to cleanup the big
> at803x PHY driver.
> 
> It currently have 3 different family of PHY in it. at803x, qca83xx
> and qca808x.
> 
> The current codebase required lots of cleanup and reworking to
> make the split possible as currently there is a greater use of
> adding special function matching the phy_id.
> 
> [...]

Here is the summary with links:
  - [net-next,v4,01/13] net: phy: at803x: fix passing the wrong reference for config_intr
    https://git.kernel.org/netdev/net-next/c/f8fdbf3389f4
  - [net-next,v4,02/13] net: phy: at803x: move disable WOL to specific at8031 probe
    https://git.kernel.org/netdev/net-next/c/6a3b8c573b5a
  - [net-next,v4,03/13] net: phy: at803x: raname hw_stats functions to qca83xx specific name
    https://git.kernel.org/netdev/net-next/c/07b1ad83b9ed
  - [net-next,v4,04/13] net: phy: at803x: move qca83xx specific check in dedicated functions
    https://git.kernel.org/netdev/net-next/c/d43cff3f8233
  - [net-next,v4,05/13] net: phy: at803x: move specific DT option for at8031 to specific probe
    https://git.kernel.org/netdev/net-next/c/900eef75cc50
  - [net-next,v4,06/13] net: phy: at803x: move specific at8031 probe mode check to dedicated probe
    https://git.kernel.org/netdev/net-next/c/25d2ba94005f
  - [net-next,v4,07/13] net: phy: at803x: move specific at8031 config_init to dedicated function
    https://git.kernel.org/netdev/net-next/c/3ae3bc426eaf
  - [net-next,v4,08/13] net: phy: at803x: move specific at8031 WOL bits to dedicated function
    https://git.kernel.org/netdev/net-next/c/27b89c9dc1b0
  - [net-next,v4,09/13] net: phy: at803x: move specific at8031 config_intr to dedicated function
    https://git.kernel.org/netdev/net-next/c/30dd62191d3d
  - [net-next,v4,10/13] net: phy: at803x: make at8031 related DT functions name more specific
    https://git.kernel.org/netdev/net-next/c/a5ab9d8e7ae0
  - [net-next,v4,11/13] net: phy: at803x: move at8031 functions in dedicated section
    https://git.kernel.org/netdev/net-next/c/f932a6dc8bae
  - [net-next,v4,12/13] net: phy: at803x: move at8035 specific DT parse to dedicated probe
    https://git.kernel.org/netdev/net-next/c/21a2802a8365
  - [net-next,v4,13/13] net: phy: at803x: drop specific PHY ID check from cable test functions
    https://git.kernel.org/netdev/net-next/c/ef9df47b449e

You are awesome, thank you!