[v1,0/8] drm/etnaviv: Various cleanup

Message ID 20230623100822.274706-1-sui.jingfeng@linux.dev
Headers
Series drm/etnaviv: Various cleanup |

Message

Sui Jingfeng June 23, 2023, 10:08 a.m. UTC
  From: Sui Jingfeng <suijingfeng@loongson.cn>

No functional change.

Sui Jingfeng (8):
  drm/etnaviv: Using the size_t variable to store the number of pages
  drm/etnaviv: Using the unsigned int type to count the number of pages
  drm/etnaviv: Drop the second argument of the etnaviv_gem_new_impl()
  drm/etnaviv: Remove surplus else after return
  drm/etnaviv: Keep the curly brace aligned
  drm/etnaviv: No indentation by double tabs
  drm/etnaviv: Add dedicated functions to create and destroy platform
    device
  drm/etnaviv: Add a helper to get a pointer to the first available node

 drivers/gpu/drm/etnaviv/etnaviv_drv.c       | 100 +++++++++++++-------
 drivers/gpu/drm/etnaviv/etnaviv_gem.c       |  14 +--
 drivers/gpu/drm/etnaviv/etnaviv_gem_prime.c |   7 +-
 3 files changed, 77 insertions(+), 44 deletions(-)
  

Comments

Sui Jingfeng July 17, 2023, 8:36 a.m. UTC | #1
Hi, Dear etnaviv folks


Would you like to review this cleanup patch set ?

I am asking because I'm wondering that

if I should re-spin my other patch from the code base

which *with* this series applied or from the code base

*without* this series applied.


I think this series looks fine, is it acceptable?


On 2023/6/23 18:08, Sui Jingfeng wrote:
> From: Sui Jingfeng <suijingfeng@loongson.cn>
>
> No functional change.
>
> Sui Jingfeng (8):
>    drm/etnaviv: Using the size_t variable to store the number of pages
>    drm/etnaviv: Using the unsigned int type to count the number of pages
>    drm/etnaviv: Drop the second argument of the etnaviv_gem_new_impl()
>    drm/etnaviv: Remove surplus else after return
>    drm/etnaviv: Keep the curly brace aligned
>    drm/etnaviv: No indentation by double tabs
>    drm/etnaviv: Add dedicated functions to create and destroy platform
>      device
>    drm/etnaviv: Add a helper to get a pointer to the first available node
>
>   drivers/gpu/drm/etnaviv/etnaviv_drv.c       | 100 +++++++++++++-------
>   drivers/gpu/drm/etnaviv/etnaviv_gem.c       |  14 +--
>   drivers/gpu/drm/etnaviv/etnaviv_gem_prime.c |   7 +-
>   3 files changed, 77 insertions(+), 44 deletions(-)
>
  
Lucas Stach July 17, 2023, 10:09 a.m. UTC | #2
Hi Jingfeng,

Am Montag, dem 17.07.2023 um 16:36 +0800 schrieb suijingfeng:
> Hi, Dear etnaviv folks
> 
> 
> Would you like to review this cleanup patch set ?
> 
> I am asking because I'm wondering that
> 
> if I should re-spin my other patch from the code base
> 
> which *with* this series applied or from the code base
> 
> *without* this series applied.
> 
> 
> I think this series looks fine, is it acceptable?
> 
I've gone through the series and left some comments. All patches that I
didn't comment on look fine to me. I'm generally in favor of taking
this series.

Regards,
Lucas

> 
> On 2023/6/23 18:08, Sui Jingfeng wrote:
> > From: Sui Jingfeng <suijingfeng@loongson.cn>
> > 
> > No functional change.
> > 
> > Sui Jingfeng (8):
> >    drm/etnaviv: Using the size_t variable to store the number of pages
> >    drm/etnaviv: Using the unsigned int type to count the number of pages
> >    drm/etnaviv: Drop the second argument of the etnaviv_gem_new_impl()
> >    drm/etnaviv: Remove surplus else after return
> >    drm/etnaviv: Keep the curly brace aligned
> >    drm/etnaviv: No indentation by double tabs
> >    drm/etnaviv: Add dedicated functions to create and destroy platform
> >      device
> >    drm/etnaviv: Add a helper to get a pointer to the first available node
> > 
> >   drivers/gpu/drm/etnaviv/etnaviv_drv.c       | 100 +++++++++++++-------
> >   drivers/gpu/drm/etnaviv/etnaviv_gem.c       |  14 +--
> >   drivers/gpu/drm/etnaviv/etnaviv_gem_prime.c |   7 +-
> >   3 files changed, 77 insertions(+), 44 deletions(-)
> > 
>