[v5,0/3] Simplify extcon_dev_register function.

Message ID 20230320031939.28862-1-bw365.lee@samsung.com
Headers
Series Simplify extcon_dev_register function. |

Message

Bumwoo Lee March 20, 2023, 3:19 a.m. UTC
  It was modified to increase readability.

Changes from v4:
added null checking of edev on each function.

Chages from v3:
removed possibility of kfree(NULL).

Chages from v2:
resolved possible memory leak of dev->cables.

Changes from v1:
added return value handling.

Bumwoo Lee (3):
  extcon: Add extcon_alloc_cables to simplify extcon register function
  extcon: Add extcon_alloc_muex to simplify extcon register function
  extcon: Add extcon_alloc_groups to simplify extcon register function

 drivers/extcon/extcon.c | 281 +++++++++++++++++++++++-----------------
 1 file changed, 165 insertions(+), 116 deletions(-)
  

Comments

Chanwoo Choi March 20, 2023, 8:33 p.m. UTC | #1
On 23. 3. 20. 12:19, Bumwoo Lee wrote:
> It was modified to increase readability.
> 
> Changes from v4:
> added null checking of edev on each function.
> 
> Chages from v3:
> removed possibility of kfree(NULL).
> 
> Chages from v2:
> resolved possible memory leak of dev->cables.
> 
> Changes from v1:
> added return value handling.
> 
> Bumwoo Lee (3):
>   extcon: Add extcon_alloc_cables to simplify extcon register function
>   extcon: Add extcon_alloc_muex to simplify extcon register function
>   extcon: Add extcon_alloc_groups to simplify extcon register function
> 
>  drivers/extcon/extcon.c | 281 +++++++++++++++++++++++-----------------
>  1 file changed, 165 insertions(+), 116 deletions(-)
> 

Applied them. Thanks.