[v4,0/4] Simplify extcon_dev_register function.

Message ID 20230302090143.46678-1-bw365.lee@samsung.com
Headers
Series Simplify extcon_dev_register function. |

Message

Bumwoo Lee March 2, 2023, 9:01 a.m. UTC
  It was modified to increase readability.

Chages from v3:
removed possibility of kfree(NULL).

Chages from v2:
resolved possible memory leak of dev->cables.

Changes from v1:
added return value handling.

Bumwoo Lee (4):
  extcon: Removed redundant null checking for class
  extcon: Added extcon_alloc_cables to simplify extcon register function
  extcon: Added extcon_alloc_muex to simplify extcon register function
  extcon: Added extcon_alloc_groups to simplify extcon register function

 drivers/extcon/extcon.c | 293 +++++++++++++++++++++++-----------------
 1 file changed, 166 insertions(+), 127 deletions(-)