[v2,0/9] selftests/resctrl: Fixes to error handling logic and cleanups

Message ID 20230215130605.31583-1-ilpo.jarvinen@linux.intel.com
Headers
Series selftests/resctrl: Fixes to error handling logic and cleanups |

Message

Ilpo Järvinen Feb. 15, 2023, 1:05 p.m. UTC
  This series fixes a few cleanup/error handling problems and cleans up
code.

v2:
- Improved changelogs
- Return NULL directly from malloc_and_init_memory()
- Added patch to convert memalign() to posix_memalign()
- Added patch to correct function comment parameter
- Dropped literal -> define patch for now (likely superceded soon)

Fenghua Yu (1):
  selftests/resctrl: Change name from CBM_MASK_PATH to INFO_PATH

Ilpo Järvinen (8):
  selftests/resctrl: Return NULL if malloc_and_init_memory() did not
    alloc mem
  selftests/resctrl: Move ->setup() call outside of test specific
    branches
  selftests/resctrl: Allow ->setup() to return errors
  selftests/resctrl: Check for return value after write_schemata()
  selftests/resctrl: Replace obsolete memalign() with posix_memalign()
  selftests/resctrl: Change initialize_llc_perf() return type to void
  selftests/resctrl: Use remount_resctrlfs() consistently with boolean
  selftests/resctrl: Correct get_llc_perf() param in function comment

 tools/testing/selftests/resctrl/cache.c       | 17 +++++++--------
 tools/testing/selftests/resctrl/cat_test.c    |  4 ++--
 tools/testing/selftests/resctrl/cmt_test.c    |  9 ++++----
 tools/testing/selftests/resctrl/fill_buf.c    |  7 +++++--
 tools/testing/selftests/resctrl/mba_test.c    | 11 +++++++---
 tools/testing/selftests/resctrl/mbm_test.c    |  4 ++--
 tools/testing/selftests/resctrl/resctrl.h     |  6 ++++--
 tools/testing/selftests/resctrl/resctrl_val.c | 21 +++++++------------
 tools/testing/selftests/resctrl/resctrlfs.c   |  2 +-
 9 files changed, 41 insertions(+), 40 deletions(-)
  

Comments

Reinette Chatre March 16, 2023, 4:01 p.m. UTC | #1
Hi Ilpo,

On 2/15/2023 5:05 AM, Ilpo Järvinen wrote:
> This series fixes a few cleanup/error handling problems and cleans up
> code.
> 

Thank you very much. These are great cleanups. Looks like I missed
sending one response with the others but at this time all patches
in this series should have my Reviewed-by tag.

If the Kselftest team finds them acceptable I hope that they
can help to route them upstream.

Reinette