devres: rename the first parameter of devm_add_action_or_reset()

Message ID 20230907110305.2096052-1-masahiroy@kernel.org
State New
Headers
Series devres: rename the first parameter of devm_add_action_or_reset() |

Commit Message

Masahiro Yamada Sept. 7, 2023, 11:03 a.m. UTC
  Fix a possible mistake in commit 410e7088e971 ("devres: Pass unique name
of the resource to devm_add_action_or_reset()").

The first parameter of devm_add_action_or_reset() is the associated
device. The name 'release' is confusing because it is often used for
dr_release_t in the devres context.

Rename it to 'dev'. No functional change intended.

Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
---

 include/linux/device.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
  

Comments

andy@kernel.org Sept. 7, 2023, 2:07 p.m. UTC | #1
On Thu, Sep 07, 2023 at 08:03:05PM +0900, Masahiro Yamada wrote:
> Fix a possible mistake in commit 410e7088e971 ("devres: Pass unique name
> of the resource to devm_add_action_or_reset()").
> 
> The first parameter of devm_add_action_or_reset() is the associated
> device. The name 'release' is confusing because it is often used for
> dr_release_t in the devres context.
> 
> Rename it to 'dev'. No functional change intended.

...

> -#define devm_add_action_or_reset(release, action, data) \
> -	__devm_add_action_or_reset(release, action, data, #action)
> +#define devm_add_action_or_reset(dev, action, data) \
> +	__devm_add_action_or_reset(dev, action, data, #action)

What about devm_add_action() and Co?
  
Masahiro Yamada Sept. 8, 2023, 1:58 p.m. UTC | #2
On Thu, Sep 7, 2023 at 11:24 PM Andy Shevchenko <andy@kernel.org> wrote:
>
> On Thu, Sep 07, 2023 at 08:03:05PM +0900, Masahiro Yamada wrote:
> > Fix a possible mistake in commit 410e7088e971 ("devres: Pass unique name
> > of the resource to devm_add_action_or_reset()").
> >
> > The first parameter of devm_add_action_or_reset() is the associated
> > device. The name 'release' is confusing because it is often used for
> > dr_release_t in the devres context.
> >
> > Rename it to 'dev'. No functional change intended.
>
> ...
>
> > -#define devm_add_action_or_reset(release, action, data) \
> > -     __devm_add_action_or_reset(release, action, data, #action)
> > +#define devm_add_action_or_reset(dev, action, data) \
> > +     __devm_add_action_or_reset(dev, action, data, #action)
>
> What about devm_add_action() and Co?


I will fix devm_add_action too.


Thanks.




> --
> With Best Regards,
> Andy Shevchenko
>
>
  

Patch

diff --git a/include/linux/device.h b/include/linux/device.h
index 56d93a1ffb7b..1fa0e9cb5e01 100644
--- a/include/linux/device.h
+++ b/include/linux/device.h
@@ -403,8 +403,8 @@  static inline int __devm_add_action_or_reset(struct device *dev, void (*action)(
 
 	return ret;
 }
-#define devm_add_action_or_reset(release, action, data) \
-	__devm_add_action_or_reset(release, action, data, #action)
+#define devm_add_action_or_reset(dev, action, data) \
+	__devm_add_action_or_reset(dev, action, data, #action)
 
 /**
  * devm_alloc_percpu - Resource-managed alloc_percpu