net: bluetooth: Use kzalloc instead of kmalloc/memset
Commit Message
This commit replace kmalloc + memset to kzalloc
for better code readability and simplicity.
Following messages are related cocci warnings.
WARNING: kzalloc should be used for d, instead of kmalloc/memset
Signed-off-by: Kang Minchul <tegongkang@gmail.com>
---
net/bluetooth/hci_conn.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
Comments
Hello:
This patch was applied to bluetooth/bluetooth-next.git (master)
by Luiz Augusto von Dentz <luiz.von.dentz@intel.com>:
On Sun, 30 Oct 2022 05:45:41 +0900 you wrote:
> This commit replace kmalloc + memset to kzalloc
> for better code readability and simplicity.
>
> Following messages are related cocci warnings.
>
> WARNING: kzalloc should be used for d, instead of kmalloc/memset
>
> [...]
Here is the summary with links:
- net: bluetooth: Use kzalloc instead of kmalloc/memset
https://git.kernel.org/bluetooth/bluetooth-next/c/214c507d87cc
You are awesome, thank you!
@@ -824,11 +824,10 @@ static int hci_le_terminate_big(struct hci_dev *hdev, u8 big, u8 bis)
bt_dev_dbg(hdev, "big 0x%2.2x bis 0x%2.2x", big, bis);
- d = kmalloc(sizeof(*d), GFP_KERNEL);
+ d = kzalloc(sizeof(*d), GFP_KERNEL);
if (!d)
return -ENOMEM;
- memset(d, 0, sizeof(*d));
d->big = big;
d->bis = bis;
@@ -861,11 +860,10 @@ static int hci_le_big_terminate(struct hci_dev *hdev, u8 big, u16 sync_handle)
bt_dev_dbg(hdev, "big 0x%2.2x sync_handle 0x%4.4x", big, sync_handle);
- d = kmalloc(sizeof(*d), GFP_KERNEL);
+ d = kzalloc(sizeof(*d), GFP_KERNEL);
if (!d)
return -ENOMEM;
- memset(d, 0, sizeof(*d));
d->big = big;
d->sync_handle = sync_handle;